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Pre-Migration Preparation

The following steps are recommended prior to starting a FileMaker Pro to SQL database migration 

project with FmPro Migrator.

FileMaker Pro 2,3,4 - File Preparation

There is no ODBC driver for FileMaker Pro 2,3,4 files, and the ODBC driver is required for 

transferring data from FileMaker Pro into other databases.

These older FileMaker Pro database files should be upgraded to FileMaker Pro 6 prior to 

performing the migration. 

The software download page for the licensed version of FmPro Migrator includes a FREE 

download link for FileMaker Pro 6 in order to upgrade older files.

1) Select the Help -> Check for Updates... menu item within FmPro Migrator.

The FmPro Migrator licensed software download page will be displayed in your web browser.

2) Download and install the FileMaker Pro 6 Trial Software for your computer operating system.

3) Launch the FileMaker Pro 6 software.

4) Drag & Drop the FileMaker Pro 2,3,4 files onto the FileMaker Pro 6 software window.

Each file will be converted to a new file having the .fp5 file extension used by FileMaker Pro 6.

5) Proceed to the next step - FileMaker Pro 5,6 File Preparation.

FileMaker Pro 5,6 - File Preparation

1) Make a copy of each of your FileMaker Pro files. Changes will need to be made within each file 

and you always want to be able to return to your original copy in case a problem occurs.

Select File -> Save a Copy As... -> compacted copy (smaller)

2) Rename each saved filename so that it contains no spaces or special characters. The filename 

gets used as a tablename when it is used with the ODBC driver, and spaces and special 

characters are not permitted. Therefore a filename which was originally:

Asset Management.fp5

should be changed to:

Asset_Management.fp5

If you allowed FileMaker Pro to name the file when you saved a copy, you might have ended up 

with a filename like this:

Asset Management Copy.fp5

which should be changed to:

Asset_Management.fp5

It is confusing to be dealing with lots of files named ??? Copy.fp5, so just remove the word "Copy" 
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which was appended by FileMaker Pro when you saved the file.

3) Copy all of your files into a convenient location, like a new folder so that you can keep them 

together. You might name this folder: Modified_Files in order to keep them separate from the 

original files and the empty copies of the files which will be created later. In fact, you will probably 

want to create a top-level folder to keep track of all of the files/folders which will be created during 

the migration project. 

So you could create a folder named: FM_Migration_Project

This top-level folder can then serve as the Output Directory which you will select within FmPro 

Migrator. 

Notice that each of the folders doesn't contain spaces. Under some (rare) circumstances FmPro 

Migrator may need to run migration scripts via the command line and this process only works if 

there are no spaces within any of the the folder names leading to the Output Directory. 

Open each .fp5 file saved into the Modified_Files folder and make the following changes.

4) Delete all ScriptMaker Scripts.

Select the menu: 

Scripts -> ScriptMaker...

5) Delete all Relationships. 

Select the menu:

File -> Define Relationships...

Note: Relationships are only converted to SQL databases for FileMaker Pro 7+ file versions. You 

can potentially upgrade each file into an .fp7 file if you need this feature.

6) Delete all Passwords.

Select the menu:

File -> Access Privileges -> Passwords

Make sure that the remaining un-password protected access provides Full Access to the entire file, 

with all file options checked within the dialog box.

7) Delete all fields having the following types:

Global

Summary

Unstored Calculation

Select the menu:

File -> Define Fields...

It is necessary to delete these fields from large database files having more than a few thousand 

records because the amount of time required for FileMaker Pro to perform the calculations may 

exceed the ODBC driver timeout interval. If this problem occurs, no records will be transferred from 
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exceed the ODBC driver timeout interval. If this problem occurs, no records will be transferred from 

FileMaker Pro to the destination database.

Note: You may leave the Stored Calculation fields, as the data may be valuable within the 

destination database.

It will take some work to delete recursive field dependencies. You could make one pass thru the 

fields from top to bottom to delete all of the fields which can be deleted, and then make another 

pass thru the fields list from the bottom up to the top of the list.

8) Once all of the unneeded objects have been deleted from each file - make an empty copy of 

each file. You could store the empty copy of each file within a folder named Empty_Files.

This empty copy of the database files will be used for Step 1 of the migration process where you 

will Drag & Drop the empty files onto the Step 1 icon within FmPro Migrator. This will cause FmPro 

Migrator to read the structure of each file to start the migration process.

Select the menu:

File ->  Save a Copy As... -> clone (no records)

This empty copy of each file needs to have exactly the same name as the compacted copy you 

saved previously within the Original_Files folder.

This empty copy of the file will be used by FmPro Migrator for gathering the field info from each file. 

Saving an empty copy cleans up the internal structure of the file and reduces the size of the file 

which needs to be read by FmPro Migrator and speeds up the process compared to reading a full 

copy of the file.

FileMaker Pro 7+ - File Preparation

1) (Optional) Use FileMaker Pro Advanced to export a DDR XML file from each .fp7 file.

This step is only required if you want FmPro Migrator to export relationships from FileMaker Pro 

into the destination SQL database.

2) Make a copy of each of your FileMaker Pro files. Changes will need to be made within each file 

and you always want to be able to return to your original copy in case a problem occurs.

Select File -> Save a Copy As... -> compacted copy (smaller)

Saving a compacted copy of the file cleans up the internal structure of the file and reduces the size 

of the file by removing the indexes within the file.

If you allowed FileMaker Pro to name the file when you saved a copy, you might have ended up 

with a filename like this:

Asset Management Copy.fp7
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which should be changed to:

Asset Management.fp7

It can be confusing to deal with lots of files named ??? Copy.fp7, so just remove the word "Copy" 

which was appended by FileMaker Pro when you saved the file.

3) Copy all of your files into a convenient location, like a new folder so that you can keep them 

together. You might name this folder: Modified_Files in order to keep them separate from the 

original copy of the files. In fact, you will probably want to create a top-level folder to keep track of 

all of the files/folders which will be created during the migration project. 

So you could create a folder named: FM_Migration_Project

This top-level folder can then serve as the Output Directory which you will select within FmPro 

Migrator. 

Notice that each of the folders doesn't contain spaces. Under some (rare) circumstances FmPro 

Migrator may need to run migration scripts via the command line and this process only works if 

there are no spaces within any of the the folder names leading to the Output Directory. 

Open each .fp7 file saved into the Modified_Files folder and make the following changes.

4) Delete all ScriptMaker Scripts.

Select the menu: 

Scripts -> ScriptMaker... 

or

Scripts -> Manage Scripts...

5) Delete all Relationships and non-base table TOs on the RelationshipGraph

Select the menu:

File -> Define/Manage Database...

Click the Relationships tab.

Note: If it is necessary to change the names of TOs to match base table names, while maintaining 

the relationship structure of the file, then the DDR XML file should be re-exported after making 

these changes, but before actually deleting the relationships.

Since the DDR XML file has already been exported, none of the relationships are actually needed 

for the actual data transfer part of the migration process. The FileMaker ODBC driver needs to see 

TOs on the RelationshipGraph which exactly match the name of each base table listed on the 

Tables tab.

If there are a lot of TOs and relationships on the RelationshipGraph it may be easier to delete all of 

the objects on the RelationshipGraph and then simply recreate the TOs from the existing base 

tables within the file. This can be done by clicking the Add Table button and selecting the base 

table name for each base table.
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table name for each base table.

6) Define a Primary Key for each table.

Each table must have a primary key if you want to create relationships for the table in the SQL 

database or if you want to migrate repeating fields data.

FmPro Migrator identifies the Primary Key for each table by looking for the Unique and Not Empty 

field validation options being set for any field within the table. If there are primary key fields which 

don't have these attributes set, they should be set now.

Note: If you are using FileMaker Pro Advanced, you will be able to copy and paste the table 

definitions from FileMaker Pro into FmPro Migrator via the Clipboard. FmPro Migrator will then be 

able to gather all of the attributes for each field. These attributes are also obtained from the file 

when using AppleScript on Mac OS X. 

However if you are using the ODBC interface on Windows to gather table info during the Step 1 

processing, these extra attributes won't be gathered automatically. So in this situation the primary 

key attribute needs to be specified manually within FmPro Migrator. This can be done by 

double-clicking on the primary key field within the fields list, and clicking the primary key icon for 

the field.

If the migrated tables don't actually have any field which can serve as a primary key, then a new 

field should be added as an Auto-Enter Serial Number field within the table. Then each record can 

be renumbered in Browse mode starting with 1 by clicking in the new field and selecting the 

Records -> Replace field Contents... menu. Before renumbering the records, select the Records -> 

Show All Records menu.

Once again, if it is necessary to re-define primary keys and the associated relationships within the 

database, the DDR XML file should be exported again after making these changes, but before 

deleting the relationships from within the file.

7) Verify Primary Key and Foreign Key Data Types

It is possible (but not recommended) to create relationships within FileMaker Pro databases 

between Text and Numeric field types. SQL databases will usually not accept differing data types 

when creating relationships. The field types can be corrected within the Fields tab of the 

Define/Manage Database dialog.

8) Verify Admin Account Access to File

Select the menu:

File -> Manage Accounts & Privileges

In order to transfer data from FileMaker Pro using the ODBC driver, it is necessary for FmPro 

Migrator to log into the FileMaker Pro database using a password having [Full Access] including 

ODBC access privileges within the file. The built-in Admin account already has [Full Access] 

privileges within the file, but these privileges could have been changed after the file was originally 
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privileges within the file, but these privileges could have been changed after the file was originally 

created. FileMaker 2,3,4,5,6 files may not even have an Admin account with [Full Access] 

privileges by default, depending upon how the user accounts were created within the original file.

9) Delete all fields having the following types:

Global

Summary

Unstored Calculation

Select the menu:

File -> Define/Manage Database...

It is necessary to delete these fields from large database files having more than a few thousand 

records because the amount of time required for FileMaker Pro to perform the calculations may 

exceed the ODBC driver timeout interval. If this problem occurs, no records will be transferred from 

FileMaker Pro to the destination database. The deletion of Global fields is not mandatory, but since 

Global fields don't exist within SQL databases they should be removed in order to reduce the field 

count.

Note: You may leave the Stored Calculation fields, as the data may be valuable within the 

destination database.

It will take some work to delete recursive field dependencies. You could make one pass thru the 

fields from top to bottom to delete all of the fields which can be deleted, and then make another 

pass thru the fields list from the bottom up to the top of the list.

Exporting DDR XML File

Using FileMaker 7+, select Database Design Report... from the Tools menu.

Note: Export the DDR file for the database to be migrated before removing Relationships and 



Pre-Migration Preparation - 10

Table Occurrences from the Relationship Graph. 

This DDR file will be used for importing Relationships, TOs, Value Lists, Custom Functions and 

Layouts into FmPro Migrator Developer Edition.

Exporting DDR XML File - Selecting Output Options

Within the DDR Export dialog, make sure that the database file is (1) checked for export, (2) along 

with all objects, (3) XML instead of HTML report format, then click the (4) Create button.
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Exporting DDR XML File - Selecting Output Directory

Select the output directory, then click the Save button.
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Pre-Migration Task - Delete Unstored Calc Fields

Prior to transferring data from a FileMaker Pro database into a SQL database is is usually 

necessary to delete all Unstored Calculation and Summary fields from the FileMaker Pro database 

tables. This step is usually necessary when transferring more than a few thousand records 

because the amount of time required for FileMaker Pro to calculate these values may cause an 

ODBC timeout, thus preventing the data from being transferred at all. This step should be 

completed before Step 2 - Get Fieldsize is run.

FmPro Migrator includes an automated field deletion feature which can help with this task. 
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Open Manage Deleted Fields Window

Once the FileMaker table definitions have been imported via the clipboard, the list of tables will be 

displayed within the Migration Process window.

1) Double-click on the table name, the Table Details window will be displayed. Click on the 

Manage Deleted Fields button near the top of the Table Details window, the Manage Deleted 

Fields window will open.

3) Click on the Mark for Deletion Button, all of the Unstored Calculation, Summary and Global 

fields in the selected table will be marked for deletion. Note: Global fields are also marked for 

deletion in order to reduce the number of fields of data to speed up the data transfer process. For 

the example table shown in this screenshot, there were 15 fields marked for deletion. At this point, 

the fields have not yet been deleted, they have just been marked for deletion.
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Delete Fields

1) Click the Delete Fields button. FmPro Migrator will first print a list of the ALTER TABLE SQL 

commands in the Results window, then the ALTER TABLE commands will be sent directly to the 

FileMaker database thru the ODBC connection. An example of these commands is listed below.

Note: It is common for some DROP COLUMN commands to fail as a result of Outstanding 

References by other fields. In order to resolve this issue, FmPro Migrator logs the failed DROP 

COLUMN commands and then re-sends those commands to the FileMaker Pro database again, in 

reverse order during Pass #2 processing. If PASS #2 still results in DROP COLUMN command 

failures, the remaining list of undeleted fields will be listed at the end of the processing. 

Click on the Clipboard icon to copy the commands any other software for review purposes. It will 

be helpful to have these field names available when deleting the fields manually. It is necessary to 

manually delete any fields which were not deleted automatically in order to proceed with Step #2 - 

Get Fieldsize.

ALTER TABLE "tbl_Assets" DROP COLUMN "Total Cost"

ALTER TABLE "tbl_Assets" DROP COLUMN "Total Book Value"

ALTER TABLE "tbl_Assets" DROP COLUMN "Total Depreciation"

ALTER TABLE "tbl_Assets" DROP COLUMN "Template Information Global"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteLibrary"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteSortedBy"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteCategory"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteAssignedTo"
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ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteItem"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteModel"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteSerialNumber"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteLocation"

ALTER TABLE "tbl_Assets" DROP COLUMN "SC_Full_URL_ReadWrite"

ALTER TABLE "tbl_Assets" DROP COLUMN "SC_Full_URL_ReadOnly"

ALTER TABLE "tbl_Assets" DROP COLUMN "SC_URL_Prefix"

Field 1 of 15 Processed [Pass #1].

Field 2 of 15 Processed [Pass #1].

Field 3 of 15 Processed [Pass #1].

Field 4 of 15 Processed [Pass #1].

Field 5 of 15 Processed [Pass #1].

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteLibrary"

[FileMaker][FileMaker]  (13): Outstanding references

Field 6 of 15 Processed [Pass #1].

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteSortedBy"

[FileMaker][FileMaker]  (13): Outstanding references

Field 7 of 15 Processed [Pass #1].

Field 8 of 15 Processed [Pass #1].

Field 9 of 15 Processed [Pass #1].

Field 10 of 15 Processed [Pass #1].

Field 11 of 15 Processed [Pass #1].

Field 12 of 15 Processed [Pass #1].

Field 13 of 15 Processed [Pass #1].

Field 14 of 15 Processed [Pass #1].

Field 15 of 15 Processed [Pass #1].

Field 1 of 2 Processed [Pass #2].

Field 2 of 2 Processed [Pass #2].

----------      Completed     ----------
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Adding Deleted Fields to the SQL Database [PHP Conversion Only]

After the table has been created in the SQL database, and the data transferred to the SQL 

database, the deleted columns can then be added to the SQL database table. 

Note: This step is only needed if a PHP Conversion project is being generated, in order to insure 

that the database columns referenced in the CakePHP Model files exist within the database table.

ALTER TABLE tbl_assets ADD total_cost DOUBLE NULL;

ALTER TABLE tbl_assets ADD total_book_value DOUBLE NULL;

ALTER TABLE tbl_assets ADD total_depreciation DOUBLE NULL;

ALTER TABLE tbl_assets ADD template_information_global TEXT NULL;

ALTER TABLE tbl_assets ADD hilitelibrary BLOB NULL;

ALTER TABLE tbl_assets ADD hilitesortedby TEXT NULL;

ALTER TABLE tbl_assets ADD hilitecategory BLOB NULL;

ALTER TABLE tbl_assets ADD hiliteassignedto BLOB NULL;

ALTER TABLE tbl_assets ADD hiliteitem BLOB NULL;

ALTER TABLE tbl_assets ADD hilitemodel BLOB NULL;

ALTER TABLE tbl_assets ADD hiliteserialnumber BLOB NULL;

ALTER TABLE tbl_assets ADD hilitelocation BLOB NULL;

ALTER TABLE tbl_assets ADD sc_full_url_readwrite TEXT NULL;

ALTER TABLE tbl_assets ADD sc_full_url_readonly TEXT NULL;

ALTER TABLE tbl_assets ADD sc_url_prefix TEXT NULL;

Field 1 of 15 Processed.

Field 2 of 15 Processed.

Field 3 of 15 Processed.
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Field 4 of 15 Processed.

Field 5 of 15 Processed.

Field 6 of 15 Processed.

Field 7 of 15 Processed.

Field 8 of 15 Processed.

Field 9 of 15 Processed.

Field 10 of 15 Processed.

Field 11 of 15 Processed.

Field 12 of 15 Processed.

Field 13 of 15 Processed.

Field 14 of 15 Processed.

Field 15 of 15 Processed.
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